Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 21 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
I recently turned on my signal light and it was hyper blinking ...but all of my signal lights were working just blinking fast...the only problem is that was my signal light blinks my reverse lights blink as well ..has anyone experience this or is this something that jeeps usually do I've never seen it before ..
 

·
Registered
Joined
·
4,109 Posts
Have you done any mods to any of the lights.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
Atthehop said:
Have you done any mods to any of the lights.
I recently put in trailer wiring about 6 months ago ...it was a quick connect and I have checked the ground in the ground is still solid ...and I replaced both turn signal bulbs about 2 months ago ..
 

·
Registered
Joined
·
3 Posts
I recently had this exact problem. My recommendation is check your bulbs, if they're ok, it's probably your switch in the steering wheel.

$40 at auto zone.
 

·
Registered
Joined
·
4,109 Posts
It could be a bad bulb, I seen a dual filament bulb cause weird problems because the two filaments in the bulb were touching each other. Bulbs are cheap, buy one and swap each one out one at a time to see if it dtops.
 

·
Registered
Joined
·
70 Posts
When mine does that it is usually a loose ground. It will also do it when the trailer is connected and note grounded properly.
 

·
Registered
Joined
·
4,109 Posts
Do you happen to have brush guards on the rear lamps.
 

·
Registered
Joined
·
1,360 Posts
Had a problem similar to this on my Jeep. Come to find out the trailer plug harness had rubbed just a little bit on the frame allowing moisture to enter and corrode the trailer harness. Just looking at it and inspecting it you would have never known. It wasn't till I noticed the green crap coming out of the wire did I know it was the problem.
 

·
Registered
Joined
·
181 Posts
Mine was acting just like that when I bought my jeep, fast flashing no brake lights and all kinds of crazy stuff. My Son had it at work doing an inspection on it and was troubleshooting the problem when one of his co-workers came by and grabbed the blinker switch and banged it back and forth several times between left turn, off, and right turn. It has been working ever since. I guess when he got rough with the turn indicator switch it must have knocked some corrosion off of the contacts or something. Also the Jeep had been parked for a couple of years under a carport with the sides and back open.
 

·
Registered
Joined
·
4,109 Posts
Yeah I do.
Brush guards are well known for bad grounds since the tail lamps ground through the mounting screws. Remove them and ensure the screws are making good grounds.
 

·
Registered
Joined
·
4,109 Posts
???????? Gave up.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #20 ·
wiring plug was a quick connect. ground is fine. stopped hyper blinking all of a sudden. still both reverse light blink the when i turn on my right signal light. theyre pretty dim tho. the filaments seem to be fine as well.
 
1 - 20 of 21 Posts
Top