Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So I lost my clutch a week after buying my 92 wrangler and I'm guessing it's the slave cylinder. On this model they put the stupid thing inside the bell housing of the tranny. Why? And how stupid. Fought with this install a while, finally got it swapped out. Having trouble getting front drive yoke back on, does this just need tapped back on?

Anyone else have difficulties? Is bleeding the slave a hard task? Why is there not much on YouTube ab this. The questions come up in all kinds of forums.
 

·
Registered
Joined
·
204 Posts
Idk why you pulled the yoke off. I just pulled the driveshaft at the axle. As far as bleeding goes, it does take a little time. Just be sure you dont let the master go dry or it's ack to square one again. The instructions with the kit I used said to pump the clutch at least 20 times to get it to bleed. They weren't kidding either. Once it got a little pedal to it, it bled out easily. Did you check your clutch, pressure plate and flywheel while you had it apart? Also did you get a look at your rear main seal. If you have a 2.5l it's a one piece and the only way to change it is to pull it all apart again. For me it was worth being proactive and doing it all since it was apart. I don't like having to do the same job twice.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for input. The axle slipped right out when working on separating the bell housing from plate. We intended on taking loose at axle. It's the 4.0 and we checked all clutch and others. Those two reverse torx e14 bolts on the top of trans were aweful to get to. I hope this works.
 
1 - 3 of 3 Posts
Top