Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of January's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I just got a 1990 Sahara with only 88,500 miles on it.
When I go to start the jeep, it tries to turn over and then doesn't start. Then on the second time it will start. Furthermore, on different occasions, it will start up only after the 4th/5th time. After use and turning it off. I can start it up on the first try.

Do I have a starter problem??

Should I be concerned?

Thoughts, ideas, concerns?

Thanks!
 

·
Registered
Joined
·
2,013 Posts
Welcome to the forum...

What engine?
 

·
Registered
Joined
·
787 Posts
"Doesn't start"

Meaning.... what does it sound like? normal? battery dying? Half ass starting and shutting off?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
So after a little research and primarily talking to the mechanic (which then made me actually read the owner's manual)...

My inline 6 in this fine 1990 Wrangler has a carburetor that needs to be primed if it has sat idle for a period of time or if it is a cold start. This is done by stepping on the gas twice and then starting the vehicle. If it is cold... step on it maybe three times.

Thank you everyone for helping me with this issue. I hope that someone can find this helpful in the future. Glad a I found a new home on wranglerforum.com !!!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Update: So I continued to start my Jeep like a lawnmower with "giving it some gas" while starting it up. Then on a drive home, the engine cut out to never start up again...

Think it's the fuel pump? Carb? Open to suggestions

Thanks
 

·
Registered
Joined
·
26 Posts
Update: So I continued to start my Jeep like a lawnmower with "giving it some gas" while starting it up. Then on a drive home, the engine cut out to never start up again...

Think it's the fuel pump? Carb? Open to suggestions

Thanks
I just had exactly the same problem (in exactly the same model/year jeep!)

Over a few months became strange to start. Sometimes cutting out, until dying completely on a short drive home (I also noticed the tacho/rev counter behaving oddly, whizzing around without the engine revving).

I disconnected the fuel hose to the carb and cranked half a turn. Fuel pouring out, so not the pump! Checked the spark by unplugging a spark plug boot, placing a (fat-handled) phillips screwdriver blade into the removed boot and placing the exposed screwdrive blade very close (but not touching) earthed metal. Made sure I was ONLY touching the insulated handle. Buddy cranked... no spark, so I changed the coil. No change!

My problem was the Ignition Control Module (ICU) which sits under the coolant expansion bottle, bolted to the passenger side wheelarch.



It took me longer to FIND it, than it did to drive to the store buy a new one and fit! I dont think there is an easy way to diagnose if the ICU is faulty, but they're about $60, so I just bit the bullet. A coil is cheaper, you could start there.

Here's what I'm on about

Andy
 

·
NASCAR JEEP!!!!
Joined
·
470 Posts
Andy, first off, Cayman Islands? you suck!!!!! other than that, thanks for this. I am starting to experience a hard start at times and I will keep this in mind.!
 
1 - 8 of 8 Posts
Top