Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
The other morning it was about 20 degrees and when I started my car it sounded like the belt was loose and making an incredibly loud shrieking noise. I thought it might have something to do with the cold temp however now it does it every now and then. Should I replace my belt or do I need to check something else out?
 

·
Registered
Joined
·
343 Posts
Had the same thing happen to me. Not sure what it was....having my mechanic look at it. Could be a loose belt, or the tensioner
 

·
Registered
Joined
·
419 Posts
any possibility you have a small coolant leak and a bit is getting on the belt?

if its a tensioner it probably wouldn't be intermittent
 

·
Registered
Joined
·
343 Posts
Kuda0005 will you let me know what your mechanic says? I appreciate the feedback
Will do. What's weird is that the noise goes away over time (when Cappy is all warmed up).

Yeah....Cappy....my son named him for Captain America. We will be putting the shield on the wheel cover on the rear of the jeep.
 

·
Registered
Joined
·
8,397 Posts
Likely the belt needs to be a smidge tighter. If you have a spring tensioner, you may just need to replace the belt.
 

·
Registered
Joined
·
2 Posts
Same thing happened to me. I replaced the belt and tensioner. Didn't help. So I WD-40'd the alternator and it quit. I'm keeping a leery eye on things but so far....
 
1 - 8 of 8 Posts
Top