Jeep Wrangler Forum banner

Speedometer not working

2411 11
I have a 95 yj, I bought it with the speedometer not working. I tried changing the speed sensor. Checked the voltage at the speed sensor and its there. I bought a used cluster and replaced that and it still doesn't work, unless the new used cluster is bad. Any ideas?
1 - 12 of 12 Posts

·
Registered
Joined
·
4,757 Posts
I would say that its in the circuit board on the back side of the speedo. Maybe do a continuity test on the wiring harness from the t-case to the dash.

The circuit board is a very sensitive, POS, that was a bad idea from day one. And expensive to replace as well. If the light doesnt work either, and you have deciphered that it isnt just a bad bulb, then perhaps it might be a bad ground to the circuit board.
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #5 ·
Thanks ill check that, I thought for sure it was the gauge cluster until I installed the new one and it did exactly what the old one did. I found it very odd that all the lights work except the speedometer light even with the new used speedometer. What's the chances of buying another bad speedometer. LOl
 

·
Super Moderator
Joined
·
17,562 Posts
The last time Crash98 posted was in Aug 2014. He may not see your post. It'd be better to start a new thread describing all your symptoms and everything you've done to try to cure your issue.

Good Luck, L.M.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top