Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
i have an '95 yj that begins to spit and sputter after ten or so minutes of driving. i let it warm up daily and i did a full tune-up over the weekend which did not repair the issue. i figured it may have been a cracked rotor or bad wires, but they were both fine (old, and all, but fine).

so, i give it gas and it just cuts in and out, like it wants to die, but doesn't have the heart to do so, and then it will jerk back to the rpm i was at if i keep my foot on the skinny. real jerky if i keep my foot on the gas pedal, low rpms if i take my foot off of the gas pedal. it does this for about five minutes then stops, hereby causing my check engine light to come on. i checked the codes, and the only code thrown was the 02 sensor code. i have two ideas, but would REALLY love some help or feedback: 1. bad throttle position sensor? 2. maybe the bad 02 sensor is somehow clogging the fuel? i really don't know what else it could be, especially since no other codes are thrown.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #2 ·
also, shifting into fifth gear seems to make the problem happen quicker. thankssssss
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
yes it does. it begins to feel that way midway through third gear, fourth and fifth gear seem to beg for fuel.
 

·
Registered
Joined
·
36 Posts
Sputtering and spitting too

My jeep just started doing it too. Please tell me if you have found out what the problem is. I replaced the obvious parts. I still cant find the problem.
 

·
Registered
Joined
·
28 Posts
If you rev it high in first or second gears will it sputter? Did you change out your fuel filter with your tune up?
 

·
Registered
Joined
·
17 Posts
Hmmm... I literally got on here to do post the same issue. I've got a 90 YJ with 158,000 miles on it. Just changed out the spark plugs and wires and it has started doing this too. To me it seems as if it's a cold weather thing. Once I get it warm, it doesn't do it. Any thoughts?
 

·
Registered
Joined
·
41 Posts
My jeep has the O2 sensor code come up now. Where can I get this dry gas?
I have the o2 sensor thing too, I just havent had it replaced yet. Seems unrelated to this issue though. I got my dry gas at pep boys so any auto supply store or gas station should have it. It's like 2 bucks for the bottle.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #12 ·
i have no cat ;p

my exhaust ends under the passenger seat. my cat got a good lick, took it off and welded a straight pipe on, then the muffler got ripped off. anyways, i bought a tps and i'll install it tomorrow. i'll let everyone know if that works. the o2 sensor wouldn't cause that problem.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #13 ·
and yes, i did replace the fuel filter.
 
1 - 13 of 13 Posts
Top