Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello, the sway bar module of my Jk stop working. I searched a new one but is really expensive and Import it to my country (Peru) is not so easy. At the moment the sway bar indication is blinking in my board. There is any way to erase it without fixing the module?
 

·
Retired Moderator
Joined
·
100,658 Posts
:welcome: to the Forum..:wavey:
 
  • Like
Reactions: Rodrigolawer

·
Registered
Joined
·
2 Posts
I had the same issue on my 2016 JK Rubicon about 6 months ago, reading on this forum, I took the electronic connector apart, cleaned with electrical spray cleaner, packed with dielectric grease, and has worked like a charm ever since, including light on dash going off.
 

·
Retired Moderator
Joined
·
100,658 Posts
I had the same issue on my 2016 JK Rubicon about 6 months ago, reading on this forum, I took the electronic connector apart, cleaned with electrical spray cleaner, packed with dielectric grease, and has worked like a charm ever since, including light on dash going off.
Welcome to the Forum.
 

·
Registered
Joined
·
2 Posts
Thanks Old Dogger ……………. I've actually been around since 2016 …………… don't know why it shows my first post …………. then again, I've belonged to several of these forums for years, so maybe it is my first post here …………. LOL
 

·
Registered
Joined
·
3,204 Posts
I had the same issue on my 2016 JK Rubicon about 6 months ago, reading on this forum, I took the electronic connector apart, cleaned with electrical spray cleaner, packed with dielectric grease, and has worked like a charm ever since, including light on dash going off.
This ^^^^^
 

·
Registered
Joined
·
2,105 Posts
I had the same issue on my 2016 JK Rubicon about 6 months ago, reading on this forum, I took the electronic connector apart, cleaned with electrical spray cleaner, packed with dielectric grease, and has worked like a charm ever since, including light on dash going off.
I did that twice and gave up after the second cleaning went bad. I got a EVO 1087 and a AEV ProCal in a package and replaced the motor and shut off the light. The plug has been zip tied to cross member since.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
I had the same issue on my 2016 JK Rubicon about 6 months ago, reading on this forum, I took the electronic connector apart, cleaned with electrical spray cleaner, packed with dielectric grease, and has worked like a charm ever since, including light on dash going off.
I did that but nothing.
 

·
Super Moderator
Joined
·
6,795 Posts
I did that but nothing.
Then like terpsmandan said, you can get a ProCal and turn the light off. You can also turn the light off using a phone app (like JScan) and a OBD2 widget like some have mentioned. You can also get a manual actuator from someone like EVO and still be able to manually connect and disconnect the sway bar.
 
1 - 15 of 15 Posts
Top