Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
I have a 97 TJ with the 2.5 four banger. When i try to start my jeep nothing happens at all. All my gauges still come on the radio still comes on the cb still works but it wont start. Its like its not getting power to the starter. Rarely does turning the key start the jeep, i have been having to crawl under the jeep and short out the starter to start the jeep. I have replaced the starter fuse in the fuse box many of times to see if that was the problem. Also sometimes my starter will not disengage. It well constantly keep its self engage for about 30 secs to a min. Or i have the take the battery cables off to stop it. I have already replaced the starter as well. both the fuse and the starter are less then a week old. I have ran out of ideas to fix this problem. If i am over looking something or you have any ideas that may help fix this please do! Sorry about this being so long i am just trying to express all i have done to fix this problem. Thank you all! 97REDTJ

P.S ANY AND ALL IDEAS WILL BE GREATLY APPRECIATED!!! I AM DESPERATE AT THIS POINT!!! I START SCHOOL VERY SOON AND I AM TRYING TO HURRY AND FIX THIS!!! AGAIN THANK YOU ALL!!!!
 

·
Registered
Joined
·
529 Posts
Have you checked all your connecting wires? But what it really sounds like is since you can jump the terminals to make it start and it sounds like it will crank with the key sometimes, but not always, and you have power in the "run" position, I would have to guess at it being your ignition switch having a bad or deteriorated connection. So it may need to be replaced.
 

·
Registered
Joined
·
45 Posts
I agree. Its probably the ignition switch, or the wire coming off of the ignition switch. Maybe the wire has broken its connection or rubbed through its insulation?
 

·
Administrator
Joined
·
12,622 Posts
Perhaps a bad ground as well.
 

·
Registered
Joined
·
155 Posts
I had the exact thing happen to me. There is a small peice of plastic that connect the key tumbler and the ignition switch mine broke in half and sometimes it would catch enough that it would start. we could jump start it by the fuse block under the hood. The only problem is that NO ONE selles this part. I had to buy a hole stearing colum off ebay (50 BUCKS) just to get that little brown peice. but i have an extra column
 

·
Registered
Joined
·
671 Posts
do you have a Remote starter installed in there. I've heard of cheapo RS units causing problems like that.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #9 ·
Thanks everyone for all of the quick responces, i think im about to start pricing iginition's this week. ONce again THANK YOU EVERYONE for pointing me in the right direction. ill let yall know more as i find out more.
 

·
Registered
Joined
·
169 Posts
97redtj,

i see you're running the 4 banger. i was thinking a/b putting larger tires on mine. how does the 4 banger do w/ those 33's?
 
1 - 10 of 10 Posts
Top