Jeep Wrangler Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
634 Posts
Discussion Starter #1
I have an 08 JKU with stock HU(no factory amp).

Installing a kenwood single din HU and an alpine power pack amp.

Ive got the dash kit and harness(all from bestbuy) for it. My main question is what do I need to know in regards to the wiring between the stereo/amp and speakers?.

Thanks in advance
 

·
Registered
Joined
·
539 Posts
You'll need RCA interconnects and an amp wiring kit. Check the owner's manual for the proper gauge on the amp kit.
 

·
Registered
Joined
·
3,428 Posts
And you elaborate on the amp wiring kit?
You need to supply power to the amp. It's only 15A for the Alpine power pack so you can probably get away with 10-12 gauge wire if that's the only thing you're adding. I ran an 8 gauge wire from the battery to under my dash and split it to run power to 2 Alpine power packs and the Cobra 18 CB that I put in my dash under my single DIN head unit.

I did an upgrade of my standalone (no amp) head unit on my Sport a while back. I did a write up of it here: http://www.wranglerforum.com/f274/my-stereo-install-writeup-2012-jk-sport-352618.html

Having the right wiring harnesses makes it a plug-and-play affair and it lets you use the steering wheel controls. You can get it at Amazon: http://www.amazon.com/Rp4ch11-Chrysler-Vehicles-Replacement-Interface/dp/B00AOGZ19U/ref=sr_1_2?ie=UTF8&qid=1410800439&sr=8-2&keywords=PAC+RP4-CH11
 

·
Registered
Joined
·
539 Posts
And you elaborate on the amp wiring kit?
Which Kenwood amp will you be running? Also, if you are running the stock head unit I would recommend a sound processor as you will need the pre-amp outputs. I'm using the Audiocontrol DQ-61 with my factory head unit, however you can get away with the AudioControl LC7i.
 

·
Registered
Joined
·
634 Posts
Discussion Starter #7
Which Kenwood amp will you be running? Also, if you are running the stock head unit I would recommend a sound processor as you will need the pre-amp outputs. I'm using the Audiocontrol DQ-61 with my factory head unit, however you can get away with the AudioControl LC7i.
Kenwood single din stereo
Alpine power pack amp(ktp-445u)
 

·
Registered
Joined
·
539 Posts
You should be okay with that setup. The factory HU requires a few more components and really can be a pain in the ass when adding aftermarket amps and subs. Since you are doing the aftermarket HU, you won't need the sound processor, nor will you need the amp kit with the Alpine ktp. You'll definitely need some RCA interconnects...they're pretty cheap.

For some reason I had it in my brain you were keeping the factory unit. I probably should have gotten an aftermarket HU too. :)
 
1 - 8 of 8 Posts
Top