Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
2,702 Posts
Discussion Starter #1
Doing a flush and fill on the radiator to get ready for some cooler weather day all day and longer trips, In looking for a better rust remover/inhibitor I came across a few youtubes about "Evap o Rust Thermocure" rust remover and flush.

Has anybody ever used or know of anyone and what their opinions were?

For $20 I would expect some great results. Been using prestone super flush for years satisfactorily, but always looking for something better.
 

·
Registered
Joined
·
304 Posts
I used it in a 140k mile yj 2.5 original radiator. came out dark but not as bad as I expected. Maybe that's a good thing. No negative effects as far as I know. Can't add any more.

Sent from my SM-G900V using Tapatalk
 

·
Premium Member
Joined
·
2,702 Posts
Discussion Starter #3
I used it in a 140k mile yj 2.5 original radiator. came out dark but not as bad as I expected. Maybe that's a good thing. No negative effects as far as I know. Can't add any more.

Sent from my SM-G900V using Tapatalk
LOL, Dark is good, it must work then, I ordered a bottle for the Sons ZJ as a guinea pig, his is really in need. We'll see how it turns out.
 

·
Registered
Joined
·
304 Posts
LOL, Dark is good, it must work then, I ordered a bottle for the Sons ZJ as a guinea pig, his is really in need. We'll see how it turns out.
I kept what I removed in a bucket and have soaked a few rusty metal parts in it and it removed the rust.
Typically I'll soak stuff in vinegar/water but I wanted to see how effective Thurmocure was on rust.

Sent from my SM-G900V using Tapatalk
 

·
Premium Member
Joined
·
2,702 Posts
Discussion Starter #5
Follow up...In case anyone else was as curious as I. Am very pleased with the amount of sludge that came out. After the first Drain the aluminum inside the radiator looked as it did when I put it in. The Prestone super flush would get to what I thought was clean, but there was a little yellow rust color to the aluminum left over.

Drained radiator, flushed and filled with water, ran a final rinse then drained and added the Thermocure, drove for a couple days for a few hours as per instructions. Then drained, filled, drove and repeated till I got to clear fluid. took a total of 7 cycles.

Left to Right in the pic are samples of what came out.

1st) Last drain before adding T-cure.
2nd) 1st drain after 2hrs run time at operating temp.
3rd) 2nd drain after another hour at temp.
4th) 7th and last drain. Still off color, but the water was remarkably clear of almost any particulates suspended in the water.


All in all I was pretty happy with the results, Looking forward to watching the Temp gauge on the freeway when I hit some stop n go traffic with new coolant, I sometimes get a little heat spike for a while after running 70 down the freeway for 20 mins, and then hit slow traffic with little airflow. Looking to see if this helps it a little.
 

Attachments

1 - 5 of 5 Posts
Top