Jeep Wrangler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 1977 Jeep CJ5 with a AMC 305 v8 motor. I am a weekend worrier when it comes to Jeeps. I replaced my throttle cable because it recently broke. It burned up upon ignition. The SST threaded cable heated up enough to catch the plastic grommet on fire. Know I know there is an electrical situation going on here but where. Anyone have this situation, if so how did you fix it?
 

·
Registered
Joined
·
563 Posts
The Gen3 tall deck AMC V8 sizes that came from the factory were as follows. 304,360,390,401. Unless you had an overbore you have a 304 AMC under the hood.

Can you post a picture of where the problem is happening. I would imagine you are running a carb not fuel injection. Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I do believe you are correct on the 304 motor. Yes, there is a Holley 4 barrel carb on the top. I will try to post a pic later this evening.
 

·
Registered
Joined
·
285 Posts
You have a bad ground cable. Replace or repair ground cables between the motor and firewall and the ground cable between the motor and the frame. Easy fix... Your throttle cable burned because it was acting as a ground.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Mountain

My brother in-law suggested the same solution. I check all grounds the motor ground was loose. There was also a ground coming off the neg terminal on the battery that was disconnected. I am going to reconnect the terminal wire after work today. I will let you know the out come.
 
1 - 6 of 6 Posts
Top