Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
Is this my timing chain cover? If so if I put a scope to it and verified the loud fast ticking I have been hearing when it idles is that going to be a case of a bad tensior/chain slap? It only does it under 1300 rmp whwb you get under load the sound subsides but I'm 100% positive its coming from that cover

Auto part Metal Steel
 

·
Registered
Joined
·
112 Posts
yup, that's your timing chain cover. I'm actually dealing with the exact same thing right now. I have it pulled off at the moment. Your chain is probably getting old and stretched, but it's not that big of a deal. I'm replacing my cover, chain and gear set. If it's making that sound, then you probably have metal shavings floating around in your oil.... Fix it quick and change your oil!
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #3 ·
I have a new engine only 10k on it and I did just change the oil two days ago, I'm thinking maybe a bad tensioner from the factory?
 

·
Registered
Joined
·
53 Posts
I have a similar issue that im troubleshooting today. I think its the timing chain making it. The PO wasnt real big on maintaining the old girl and now im paying for it.
 

·
Registered
Joined
·
112 Posts
On the inside of the cover, there are two tabs that hold a synthetic chain guide that eventually wears out. Normally you have to replace the cover at the same time, because the tabs are warn out from the chain slapping it. It's inexpensive and not very hard to do.

Best of luck to ya, and have fun!
 
1 - 6 of 6 Posts
Top