Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
Hey all,

After installing some grab handles in the upper corners where the windshield bolts to the rollbar, I'm getting some audible popping from the passenger side. I either have the bolts too tight or loose. Does anyone have a guess as to what the torque should be for these bolts?

Thanks!

Dan
 

·
Registered
Joined
·
91 Posts
I just checked my Grab Handle installation instructions and they do not mention any torque specs. Just "tighten". It did mention to install the top bolts first but do not tighten until the side ones are started. Then tighten all.
Have you tried taking it out & reinstalling?
 

·
Super Moderator
Joined
·
22,462 Posts
according to my grabar instructions 300 in/lbs or as tight as you can with a 3" hex head allen wrench
 

·
Registered
Joined
·
195 Posts
Discussion Starter #4
I just checked my Grab Handle installation instructions and they do not mention any torque specs. Just "tighten". It did mention to install the top bolts first but do not tighten until the side ones are started. Then tighten all.
Have you tried taking it out & reinstalling?
Thanks for the quick reply. Yeah, plan to do that. Good suggestion. I bought my Jeep used and the garb handles were in a box with no instructions. Order of bolt install is helpful. Will give that a shot.

Thanks again.

Dan
 

·
Premium Member
Joined
·
883 Posts
Sometimes the paint on the threads creates an issue, I had to run the screws threw a tap n die 'die' to clear the paint off one Jeep. The other jeep started creaking 3 months later and I had to retorque (as tight as my 6" 1/4" would go IIRC).. no more creaks
 

·
Registered
Joined
·
195 Posts
Discussion Starter #8
I wanted to close the loop on this and say thank you all for confirming that tightening those bolts to a proper torque would solve my issues. I torqued to 25ft lbs and I have to say both sides (even the one not creaking) were WAY off). Possibly cooincidently the side that has been creaking also is the side I'm getting some water leakage on. I've added some insulation that seems to have helped but not fully solved the issue. Maybe this will also help. Fingers crossed.

Took a very short drive and noticed the creaking is gone.

Again, thank you to the collective.

Dan
 

·
Registered
Joined
·
459 Posts
Threads really suck without pictures.
These are my newly installed Carolina Metal Masters billet grab bars.
Lets see yours?
IMG_1249.JPG

IMG_1252.JPG
 
1 - 9 of 9 Posts
Top