Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi All hope all is well, I have a 1999 Jeep Wrangler, 4.0 automatic, 3 speed. The other day I was driving on the highway and started to leak tranny fluid at a continuous drip I was going around 75 stopped and had it towed. Took it to a tranny shop guy told me it was front seal 500 to fix. Ok did it. Got it back going around 65 after the jeep warmed up go figure it happened again, So I call the guy he says we should hook up an tranny cooler because the tranny is over heating and blowing through the vent plug. This jeep is and has not been driven offroad or hard so I am having a hard time believing that it needs an external cooler when it never has had one and only has 66000 miles on it, but I would be game for it if it would solve the issues,, however dont want to spend 2 or 3 hundred for the external cooler and then have to rebuild the tranny because it did not work. I know you guys are the pros so I am hoping for some feedback on what you guys think I should do. I appreciate your time and thought. Thanks again, John
 

·
Knows a couple things...
Joined
·
49,386 Posts
That tranny guy is blowing smoke up your rear end. Tell him you didn't pay him to replace the seal, you paid him to fix the leak. I would tell him you'll see him in small claims court if he doesn't take care of it. And even if it overheats, it's not going to puke ATF through the vent which is located on the face of the transmission just above its input shaft. I have overheated my 32RH and it did not puke ATF through the vent.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Do you have any idea of what it could be? The radiator was replaced in march maybe an issue there? I am just lost on what to do Ijust want my wrangler back and running...
 

·
Knows a couple things...
Joined
·
49,386 Posts
Without knowing what exactly is leaking, it is hard to say. Get underneath and look, you can at least easily follow the two transmission cooler lines that go to the two bottom ports on the radiator to check them for leaks. You can eliminate the two coolant lines as potential sources of the leak by following them from where they exit the transmission on the driver's side to where they connect to the radiator. See if you can determine if the leak is coming from the front or rear of the transmission too.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
The leak is coming from the vent locaed on the bell housing, once the tranny warms up it starts coming out the vent plug, sorry if I was not clear about that. I appreciate all your help. John
 

·
Registered
Joined
·
371 Posts
Repost from JF, believe this may be your problem...............

I think I may have found the issue tonight. I drove it farther today than I have been lately and noticed the trans temp gauge going higher than normal (200°). It was monitoring the sensor in the trans pan, so I flipped the switch to check the return line sensor and it registered almost nothing (85°). I crawled under it and grabbed the cooler lines and had no trouble holding both the pressure and return lines with no discomfort. Touching the pan was very hot.

At this point I suspected a plugged trans cooler, so I bypassed my large aftermarket cooler and connected only the radiator cooler. Then I restarted the Jeep and ran it for five minutes. No change to sensor readings, and the lines were still cool. So I looped the lines back to the trans and tried it again. In about 30 seconds the two sensors showed the same reading.

I reconnected the large cooler and retested it. By blocking the tires and putting it in drive at idle, I got the trans temp back up to almost 200° on the pan sensor, but the return line is now registering 140° (a 60° drop from the cooler at a standstill with the hood open) .

Apparently there is a bypass circuit in the trans to allow fluid flow in case of the cooler lines being blocked, however it turns the trans into a pressure cooker and it will force the fluid out wherever it can.

After the test in the driveway, I took it for a drive, and so far it is not spitting out fluid anymore. I power washed everything down so I can tell if it starts again. I will try driving it a bit tomorrow to see if it is truly resolved.


Seems your tranny cooler or a cooler line may be clogged
 

·
Knows a couple things...
Joined
·
49,386 Posts
That was an awesome bit of information that very well could be the OP's problem. I hope it is!
 

·
Registered
Joined
·
371 Posts
Yea, but I would be kinda hot that a "transmission expert" couldnt tell the difference from a leaky seal (500 dollar fix) and simply blowing ATF from the vent!!!! Still, hope this fixes the OP's problem.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #15 ·
Thank ou ll for your help, I will let you know how it works out. If the tranny guy gives me any S(&t I wil take his A$$ to court Dude should ave known what to check. Thanks again all.
 
1 - 16 of 16 Posts
Top