Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
Got a problem trying to drive the Jeep in 4x4. It turns on but switches back to 2 wheel drive by itself:banghead:. Any idea what could be causing the problem. Its a 94 YJ 5 speed manual transfer case 231 got brand new oil in it so its not low in oil.
 

·
Registered
Joined
·
16 Posts
Mine is doing the same thing. When i cruise at a constant speed it stays on but when i accelerate it goes out. I couldnt trace the problem so i took it to the local shop.i will let you know what the problem was.
 

·
Registered
Joined
·
332 Posts
You could have a leak in your vacuum lines or a failing vacuum motor. Also, if you have transmission skid plate spacers or a body lift you may need to readjust the shift lever linkage.
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #4 ·
You could have a leak in your vacuum lines or a failing vacuum motor. Also, if you have transmission skid plate spacers or a body lift you may need to readjust the shift lever linkage.
the shift linkage is correct was adjusted with the body/suspention lift. It worked for a while just now it started doing it
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #5 ·
Mine is doing the same thing. When i cruise at a constant speed it stays on but when i accelerate it goes out. I couldnt trace the problem so i took it to the local shop.i will let you know what the problem was.
Ok let me know what they tell you....Thankz:punk:
 

·
Registered
Joined
·
106 Posts
You could have a leak in your vacuum lines or a failing vacuum motor.
Agree w/ Wrangler Haven...sounds like some sort of a vacuum problem. I'm leaning toward vacuum motor simply because it works for awhile then stops. Sounds like the pump is losing pressure or perhaps a leak somewhere that bleeds off the pressure.

Good luck & post what the problem & fix action is.
 

·
Registered
Joined
·
16 Posts
Mine turned out to be a bad check valve (near the fire wall) i asked about other causes and was told it could be the switch( blue) on the passenger side fire wall. This switch controls the light . Dont know the official ne of the switch but i hope this helps ya
 

·
Registered
Joined
·
38 Posts
Vacuum Diagram - JeepForum.com
JUST SCROLL DOWN

unforutly with vacuums they DO fail and if you get any water or anything in them the more trouble you will have, i personally locked the front in permanetly to a xj axel but if you look into it, the electric lockers are the way to go, posis are to but if your trying to attempt to save any money go with electric for the long run costs
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #11 ·
Thankz guys will attempt the repair come monday cause of holiday....will post pics if I find the problem
 
1 - 11 of 11 Posts
Top