Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
954 Posts
Discussion Starter · #1 ·
I have a 2015 jkur with about 89k miles. I have a check engine light. I also have a superchips trailcal that I tried to read the code with, says there are no codes to read. Drive a little today, all good. Shifted into drive, no go. Rpms increased, but nothing happened for about 2 seconds. Few miles later, parked the jeep, went to reverse, same thing. No go, trailcal didn't automatically switch to the rear camera. Back to park, then to reverse and it was fine. Did a transmission flush prior to my moab trip. Drives fine, no noise nor weird shifting. Taking in tomorrow morning to dealer, still under warranty.

Anyone else have said transmission funkiness?
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #2 ·
Went to autozone to see if their magic box could read the code, which it did. Also noticed the autostick does not work. Almost 2 years ago, did a 3.5" lift, 37s and 5.13s. All happy until today. Perusing the interwebs about said issue, found a few causes. Checked Trans fluid, its good. I'll update after it goes to the hospital tomorrow
 

Attachments

·
Registered
Joined
·
1,846 Posts
I have had something that is sort of similar but occurs in a much different scenario. 2012, and when im out wheeling in 4lo it will be all just fine for a while, shifting in and out of gear and shifting between gears. Then randomly when i shift into park and try and shift out, the same thing you are describing happens. Literally nothing happens, i can gas it and RPMs increase but it wont shift. Ill shift back and forth between drive, park, and reverse and then eventually it will jerk into gear and it will be back to normal.

I remember seeing a TSB about a similar issue while in 4lo, but i still havent made it to the dealer. Seemed that a TCM update was the fix.
 

·
Registered
Joined
·
290 Posts
First thing I'd do is take the trailcal out of the equation. Use it to set all your programming back to original factory and divorce it from your vin. Then use it to display the stock programming to ensure that all took place. Then set your tire size, then your gear ratio. Double check those changes were saved. Test the results. I've had too many crazy issues from Superchips to not try the free stuff first. Besides that the dealer may try to blame SC so you might as well be ready. Could also be a wet connector from all this rain. Were you out playing in the puddles?
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #6 ·
Did a reset on the superchips, not the jeep. Check engine was back, drove around the block and the autostick works again. 2 new codes popped up: U11C2 and U0101 which are about comms with the transmission. Reset faults with superchips, engine light went away. I reckon the jeep is happy again.

Was I playing in the puddle? Ha! That's how I wash the inside without top and doors.
 
1 - 6 of 6 Posts
Top