Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter · #1 ·
so its starting to get cold out here in mississippi and i have an issue when starting cold, i turn the key nothing no turning over sound no cranking nothing, i turn key off then back on and bam it starts with very little hesitation, im thinking maybe the battery.?.
 

·
Registered
Joined
·
688 Posts
I'm going to guess....
I would clean all of your connections related to your starting system and battery posts. Don't just look. Take them off and clean them with a wire brush and/or post cleaner brush. Then cover them with dielectric grease. I personally use mineral oil.

C.
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
Do you get any lights on the dash, radio turn on, etc...or NOTHING...like completely dead? If that's the case, definitely check your connections. Also may check your starter relay if you're getting lights and stuff?
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #4 ·
everything lights up it acts fine till i turn to crank it but it just doesnt start
 

·
Registered
Joined
·
25 Posts
Check the connection at your starter. Disconnect and clean it up and as other have suggested, clean all other connections. Sounds like an intermitten connection with your starter. Hope this helps
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #6 ·
ill check it out and hopefully it does worrk thanks ill post later with results
 
1 - 6 of 6 Posts
Top