Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Yesterday I picked up a 2016 Unlimited. Absolutely love it but I'm having one quirk I was hoping somebody can help me through. The Jeep came with the 430N unit, and everything seems to be good except for playing music from my iPhone via USB. It takes quite a while to "read" my device and many times the result is "error occurred". Restarting my iPhone fixes this temporarily. This also happened once in the middle of a song.

I did some searching around and I found some threads on this but they date back to around 2011. Is anybody having this issue or seen this issue recently? I checked the UConnect website, plugged in my VIN and it says no updates are available at this time.

My previous vehicle had an aftermarket Pioneer unit, and from time to time I would also get an error when playing music from my iPhone. But it would happen once every other week at the most. I've had the Jeep for less than 24hrs and its happened several times already.

In the meantime I'm going to try a different device, and reset my iPhone if I have better results. I wanted to throw this out there in the meantime just in case anybody has been experiencing this recently. Thanks in advance!
 

·
Registered
Joined
·
59 Posts
By "reset" do you mean rebooting the phone where you hold the power and home buttons till the Apple appears on the phone screen and then releasing them? This usually helps in many odd occurrences on Apple phones. Also another thing that I have had to do when mine did a similar thing was having to do a restore of the phone using iTunes and that really helped.
Rebooting the phone with holding power and home has been my workaround. If I have luck with another device, I will completely wipe the phone and set it up from scratch. Not even do a restore. The current state of my current iPhone was setup from a restore from my previous iPhone, my previous iPhone was setup from a restore of the iPhone before that. So I'll probably do the full reset and setup from scratch at some point anyway. I did hear from somebody at Chrysler who talked to UConnect department, and they recommended using aux port instead of USB for Apple products. Which seems kind of silly, because Apple is one of the two or three major mobile devices on the market. You'd think UConnect would fully support Apple products. Anyway, I'll see what happens with a different device and resetting my iPhone.
 

·
Registered
Joined
·
418 Posts
Also, for what it's worth? I don't think that uConnect web site is really up to date on firmware revisions for these radios?

I have a 730n, not the 430 -- but I know the web site told me I was up to date on firmware when I put my VIN in. Yet by reading the forums, confirmed that a newer version was definitely available (2.60). I even found a link to download the ISO image and burn a disc using my computer so I could upgrade it myself. It fixed quite a few issues.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
According to my system information screen, the version I have is 60.00.03. I did some quick looking around and as far as I can tell, that's the latest firmware. Firmware version aside, I did make some headway since my last post.

I'm pretty sure I found the problem and it was similar to an issue I had in my previous vehicle. Had to do with Apple Music and the music app showing songs in the cloud, and not stored on the phone locally. Basically I had a playlist with some songs downloaded on the phone and some in the cloud. When it hit one of the songs in the playlist that resided in the cloud, it stopped working. There was a setting somewhere in the settings app to disable showing songs in the cloud but not on the phone. Disabling this fixed the problem.

I remember looking for this setting with this specific issue on my 430N but didn't find it. Come to find out, in the latest version of iOS this option was moved to the Music app itself. I found this article helpful and seems to have solved my issue: How can I disable showing iTunes music purchases in iOS 9? - Ask Different

I've been playing music from my iPhone via USB since changing the above setting trouble free. No more several seconds of "reading" which 2/3 times resulted in "error occurred". Thanks for the replies, and I hope the above info is helpful to anybody else who might be experience the same problem now or in the future.
 
1 - 4 of 4 Posts
Top