Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
We were out mudding and my daughter got my JKU suck. Long story short, she spun a rod bearing getting unstuck and I just had a new Mopar rebuilt 3.8 engine installed. On our way home after she was stuck I could feel a slight vibration coming from somewhere in the streering. This would happen if we were driving or stopped. If I shut off the Jeep and restarted it usually wasn't there. It happens periodically. But it can be pretty rough at times. I don't know if this is the steering box, transmission mounts, drive line (doubt it since it does it when I'm stopped). It's not the death wobble or anything like that. More of a mild vibration, but does start to provide a lot of feedback through the steering wheel at times. When I turn the wheel I can still feel it. No issues with steering though.


Any thoughts of where to start looking?
 

·
Registered
Joined
·
24 Posts
Check your motor mounts. They could have been damaged during removal / installation of the new motor or possibly in a bind from the motor being misaligned slightly during installation.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I just had new motor mounts installed with the engine swap, and it was doing this before the swap too.

I just dropped it off at a shop today to have the interior coated. They also mentioned transmission mounts. Hoping that’s it and not something worse.
 

·
Registered
Joined
·
823 Posts
I just had new motor mounts installed with the engine swap, and it was doing this before the swap too.

I just dropped it off at a shop today to have the interior coated. They also mentioned transmission mounts. Hoping that’s it and not something worse.
Trans mount bracket can bend if the jeep is suddenly stoped by a mud pit for ex.
 
1 - 7 of 7 Posts
Top