Jeep Wrangler Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
Hey all, I opened the tailgate today and lifted the mat, and saw water where the jack is at. Any idea where it is from?cause i checked the top and around it cant find any clue.
 

·
Registered
Joined
·
1,158 Posts
It likely drips down your zipper on the drivers side, around the tailgate, and onto that tiedown. From there its a straight shot to the jack well.
 

·
Premium Member
Joined
·
376 Posts
My bad, forgot to mention that its a Hard Top.
Check the washer fluid tube in the back. That crap would always come off in my 07 JK. I remembered when I ran the fluid it would pop off and get everything wet. Jeep finally addressed that in the Hard Top redesign in 2011 I believe.
 

·
Registered
Joined
·
889 Posts
CombatChuk said:
Check the washer fluid tube in the back. That crap would always come off in my 07 JK. I remembered when I ran the fluid it would pop off and get everything wet. Jeep finally addressed that in the Hard Top redesign in 2011 I believe.
I've had the same problem. Thought it was the extra bottle of coolant I had back there for a bit but this makes much more sense. Ill have to check this out and see if I can fix it.
 

·
Registered
Joined
·
571 Posts
This happens to mine also, a hard top. I just popped out one of the rubber drain plugs and leave it off.
 

·
Registered
Joined
·
571 Posts
Check the washer fluid tube in the back. That crap would always come off in my 07 JK. I remembered when I ran the fluid it would pop off and get everything wet. Jeep finally addressed that in the Hard Top redesign in 2011 I believe.
how did they redesign this? I need to re-plug this stupid tube after every time i use it otherwise it pops out the next time.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #10
Took the plug out so the water would drain. Took a while but freed the jack that was stuck, and cleaned the compartment. just need to use anti-rust on it and grease.
 

·
Premium Member
Joined
·
376 Posts
I've had the same problem. Thought it was the extra bottle of coolant I had back there for a bit but this makes much more sense. Ill have to check this out and see if I can fix it.
In my 07 JK, the tube just went into the hardtop with no clamp whatsoever, it was a crappy design.

how did they redesign this? I need to re-plug this stupid tube after every time i use it otherwise it pops out the next time.
They permanently attached a tube to the hardtop and added this type of twist valve lock that keeps the tubes together. I haven't had any issues with it.
 

·
Registered
Joined
·
5,616 Posts
Humm this thread has gotten me to thinking. Maybe I should check my jack for rust. There has been several times that most of the water has drained out of my cooler and I bet a lot of it went into the jack compartment. Then there was the one time that the last half foot or so of my jeep was under water as I was coming out of a creak going up a waterfall. Maybe I should check on the jack in the morn.
 
1 - 14 of 14 Posts
Top