Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I drive a 2009 JKRU and I just bought it about 2 weeks ago. Every time I take my friend to lunch, I get a weird display of errors.

image-2081331662.jpg

If I turn the truck off and then back on again, it goes away. My friend is 6'6" and weighs 350, it's hilarious that it happens...but what the heck is it that needs to be replaced?
 

·
Registered
Joined
·
168 Posts
It only happens when he is in the jeep? That's weird. I would check all of your wheel speed sensors on the passenger side especially and maybe even check front passenger wheel bearing assembly. Maybe it has some wear in it and the addition of his extra weight makes it do funky stuff that the system recognizes as bad. Just a guess.
 

·
Registered
Joined
·
4,136 Posts
Is your steering wheel properly aligned? If it is off center a bit you may be ever so close to the steering wheel sesnor to think you are in a turn.
 

·
Registered
Joined
·
536 Posts
Does your cruise control stop working when it happens? Mine was doing that and eventually stayed on permanently. It was the right rear wheel speed sensor. $28 part from the dealer and 15 minutes in my garage...the lights went out before I even got out of my driveway and the cruise is working again. Like the other poster said, also check the steering wheel center. Having one or two tires with considerably different pressure in them can also throw errors. The ABS computer monitors wheel speed and steering input in order to determine whether or not to intervene. If a tire is low it will return an implausible calculation and engage the warning lights to tell you it's not happy.
Then main jist is, all four tires need to be the same diameter, the steering wheel must be properly centered and the wheel speed sensors operating for the system to work. There are some other variables but those are the three most common problems.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
What I need to do is change out all of the fluids, adjust tire pressure, and all that stuff. Diffs, tcase, tranny, radiator flush... Just rolled over 86K miles
 

·
Registered
Joined
·
158 Posts
Simple solution: find a new friend :rofl2::rofl2::rofl2:
But i am curious to see what the diagnosis ends up being
 

·
Registered
Joined
·
21 Posts
My 2007 JK has the exact same lights and my cruise doesn't work. I recently bought it and the guy has 37s on 17" rims. I'm thinking he didn't align it right or something like that maybe. Let me know what you did to fix yours.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
I recently added a 2.5" coil lift, installed it myself. No issues during install, super easy, and it only took 3.5 hours.
 

·
Registered
Joined
·
1,424 Posts
That light combo is classic symptoms of a wheel speed sensor. Its either crapping out or the connector is loose. It disables the ABS, and when one failed on my 2013 it also disabled the hill holding function.

Some code readers will tell you which wheel is reporting the error, which makes it a lot easier to narrow it down.
 
1 - 12 of 12 Posts
Top