Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
698 Posts
Discussion Starter · #1 ·
I have a Rough Country 4" lift with 1.25" lift shackles.

Problem is I started hearing a "popping" noise coming from the front end. I think it has to do with something suspension-wise. Crawled under it and found that the front track bar, where it bolts to RC's bracket, was loose. Really loose for some reason. Tightened it back up and drove it around. Still getting the noise, though not as much.

Any ideas? It is kind of muddy up under the jeep, could that be the reason for the noise? I'm going to go spray it off here shortly.
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #2 ·
bump
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #3 ·
Still happening. Every bump I hit that flexes the front axle I get the popping noise.
 

·
Registered
Joined
·
392 Posts
Did you add the dropped pitman arm? After I did mine the pitman arm started hitting the tie rod connecting rod. The pitman arm was too long.
 

·
that's what she said
Joined
·
16,481 Posts
Do you have quick disconnects on the sway bar? When mine are not disco-ed and the suspension flexed it pops.
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #6 · (Edited)
Did you add the dropped pitman arm? After I did mine the pitman arm started hitting the tie rod connecting rod. The pitman arm was too long.
Yes I did, this noise just started occurring yesterday. I've had the arm installed since June. Maybe it just started hitting?

Do you have quick disconnects on the sway bar? When mine are not disco-ed and the suspension flexed it pops.
No quick-disconnects yet. This is what the sound really does sound like though. Sounds like a coil spring popping which wouldn't be the case here. I wonder if it's just the endlink bushings packed with dirt and making noise when the swaybar flexes.

Everything looks tight and feels tight when I'm under there... :banghead:
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #7 ·
Also when the noise occurs I can feel it in the steering wheel.
 

·
Registered
Joined
·
925 Posts
I have a Rough Country 4" lift with 1.25" lift shackles.

Problem is I started hearing a "popping" noise coming from the front end. I think it has to do with something suspension-wise. Crawled under it and found that the front track bar, where it bolts to RC's bracket, was loose. Really loose for some reason. Tightened it back up and drove it around. Still getting the noise, though not as much.

Any ideas? It is kind of muddy up under the jeep, could that be the reason for the noise? I'm going to go spray it off here shortly.
I wonder if something else got loose or shifted when the track bar was loose, maybe it shifted something just enough so now it is hitting?
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #9 ·
everything looks ok. could it be a bearing?
 
1 - 9 of 9 Posts
Top