Jeep Wrangler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
QUite bizarre actually.

I was in a fast food drive thru lane and had to wait so I turned off my 2010 JK. And when I went to start it the engine started but the windshield wipers went on and I couldnt turn them off. ALso, I couldnt shift it out of park.

I was effectively stranded. I turned the engine off and on several times and finally (after 5 or so attempts) the windsheild wipers stopped and I was able to shift it out of park. Everything seemed normal again.

WTF!

Now I'm worried it will happen again and strand me for good.

Another odd thing that happened about a week ago is that I went to start it after it sitting for 8 hours and the battery was dead. I had not left any accessories on or anything.
 

·
Registered
Joined
·
124 Posts
Sounds like a dying battery and/or electrical issues, to me. When's the last time it's been replaced?

If the battery is fine, try disconnecting the battery for 20 min or so. Might be the computer having a bad hair day.
 

·
Registered
Joined
·
2,095 Posts
get new battery to start!
 

·
Registered
Joined
·
351 Posts
Your battery is probably toast. The power system does not handle low voltage situations well, and so ridiculous things will happen.


When mine died I went and pulled the negative terminal because all the relays were freaking out and going crazy. After putting in a new battery everything was perfect.



My favorite part in the electronics system that Chrysler used to use (and ended with the JK), is that they display no symptoms of a dying battery until the damn thing is dead.


All of the newer ones have electric steering though, and those will get very vocal very quickly about not having enough juice .
 

·
Registered
Joined
·
246 Posts
Test battery, check battery connections. As others have said take off negative wait 10 minutes reconnect. It is like turning off a computer having a cup of coffee and turning back on - rebooting.

Vehicles are big computers that move now days. I have had issues it was loose terminals on battery.
 
1 - 6 of 6 Posts
Top