Jeep Wrangler Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
6,426 Posts
What's your plan? That wires still good, just pull the pin and heat shrink it.
 

·
Registered
2013 Jeep Wrangler JK.
Joined
·
13 Posts
Discussion Starter · #6 ·
What's your plan? That wires still good, just pull the pin and heat shrink it.
Ultimately I am attempting to diagnose the M19 fuse (ASD #1 and #2) constantly blowing. Engine is giving an active P0688 code, ASD/main sense circuit. I was trying to see if this wire was possibly related.
 

·
Registered
2016 Wrangler JKU 3.6 Backcountry
Joined
·
448 Posts
I have a really bad memory when it come to names, but maybe Reginald 🤔


I'll get mi coat...

Anyway, easiest way to find out if it in fact is the culprit to your woes, just quickfix it with some electrical tape and see if the symptoms go away.
 

·
Registered
Joined
·
6,426 Posts
Ultimately I am attempting to diagnose the M19 fuse (ASD #1 and #2) constantly blowing. Engine is giving an active P0688 code, ASD/main sense circuit. I was trying to see if this wire was possibly related.
In your first picture, it looks like that purple wire is touching the steel heater line. It's entirely possible that is your issue. I'd tape it up and see if the issue goes away.

Is that wire solid purple or is there a stripe I cant see?
 

·
Banned
Joined
·
462 Posts
In your first picture, it looks like that purple wire is touching the steel heater line. It's entirely possible that is your issue. I'd tape it up and see if the issue goes away.
So many people have problems with the heat by those pipes that i have bought high temp electrical tape to put on this harness. Now seeing this.....ya! Im am doing it quickly this weekend.
 

·
Registered
2016 Wrangler JKU 3.6 Backcountry
Joined
·
448 Posts
Here is the wiring diagram for ASD relay. Abbreviations of english colors is not my specialty, but I'd venture a guess none of the wires here are what you are looking at.
Schematic Slope Rectangle Font Parallel

That don't mean that the cafed wire is not the culprit here...
 

·
Registered
Joined
·
1,382 Posts
Id say wrap it with some electrical tape and see how it goes. Probably dont even need to pull the pin and shrink wrap. The wire looks fine
 

·
Registered
Joined
·
7,396 Posts
The wire is solid purple, no secondary colors.
I'm not sure that's accurate. The pic is a bit foggy, but it looks to me like there is a (faded) stripe on it. It looks white or gray.

According to the wiring diagrams, there is no solid purple ("violet" actually) on the engine harness. There is a violet/Gray on pin 2 of the INLINE-INJECTOR POWERTRAIN connector. That's right next to a brown/white (pin 1) as in your picture.... which just so happens to be ASD control output
Anyway, the violet/Gray which I believe you are actually talking about is the oil pressure signal


Rectangle Slope Plot Font Line
 
1 - 14 of 14 Posts
Top