Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter #1
As the title states, my windows lose power sometimes. I know that each clip for the door power are securely attached, so it's not that. When they lose power, it's both at the same time, not just driver side or passenger side. I am able to turn the jeep off and on again and they usually work after that. What could be wrong?
 

·
Super Moderator
Joined
·
15,370 Posts
I had that happen once a while back, never did it again though. I chalked it up to a computer glitch.

Figured I hit the window button, it sent a message to the computer to roll down the window, computer sent a message to the window motor BUT that messenger stopped by the pizza place first and had one too many beers, hence the window never got rolled down. Pretty sure that's what happened in my case. :D

But seriously, I'd pop the window switch out and inspect, maybe clean it and see if that helps.

Good luck :thumb:
 

·
Registered
Joined
·
8,968 Posts
That happens to some JK's. It is a computer glitch. By cycling the ignition off/on that reconnects it. If there's still a problem, try disconnecting/reconnecting the battery for a few minutes.
 

·
Registered
Joined
·
799 Posts
It's been a problem since 2007. My rubicon unlimited did it a few times. Windows would go up but not down until a key cycle. My friend's 2012 CoD did it once so far in four years. If yours does it consistently, it could be your electronics are on the bad end of tolerances, or maybe your wiring is causing an issue with the controls. It's the reason I bought my 2015 with manual everything and as few electronics accessories as possible. Dodge/Chrysler/Jeep are pretty craptacular when it comes to electronics.

If it were my jeep, I'd look into how the power windows operate. Some embedded system somewhere sees the switch contacts close and then commands the window motors to operate. The problem is going to be in the system addressing a device or the system ignoring the switch commands due to flaws in the code. Anyone know if the system that controls the windows is located in the engine controller or a body controller?
 

·
Registered
Joined
·
236 Posts
Discussion Starter #6
I wouldn't say it's happening all the time, it has only happened three times in the last month and a half. Each time it was fixed by cycling the ignition. Easy but annoying.
 

·
Registered
Joined
·
793 Posts
Are you having any other electrical issues? Could be your TIPM is going bad. I would say take it to the dealer if you're in warranty.

A buddies TIPM went bad and his wipers wouldn't shut off and other stuff just quit working (I think headlights). Must have looked funny driving to the dealer in full sunlight with his wipers on full blast! LOL!
 
1 - 7 of 7 Posts
Top