Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
I seem to be the only one with this issue as I searched other posts and can't find anything remotely close.

I have a 2014 jk purchased new and every time it rains I can't see out the windshield. And yes, I turn the wipers on but it seems like there is a film over the windshield. The windshield gets cloudy, and no it doesn't need the defroster, but it seems like something is on the windshield . I checked it several times and cleaned it with window cleaner but when it rains its the same issue. It literally gets hard to see as the rain drops seem to leave air pockets all over the windshield. I can see little streaks of what looks like air pockets all over the entire windshield. I replaced the wipers thinking that was the problem but the new wipers do the same thing. The rear window wipes clean with the wipers but the front , I swear feels like there is a plastic film over it or something was spilled on it and it embedded itself into the windshield. I know this sounds nuts but its getting difficult to drive when it rains. It literally interferes with my vision on the road it's so bad. When the weather is clear you can see out the window perfectly, no issues at all. It's only when it rains.
Anyone else have this problem or know of a remedy?
 

·
Registered
Joined
·
238 Posts
Can't help ya with that one. You should try the JK forum, this is TJ. Not too many new windshields over here. Good luck
 

·
Registered
Joined
·
538 Posts
Windshield covered by insurance? Rocks kill windshields around here frequently...

Otherwise, have you tried Rain-X ?
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
Wow!! thx old jeep dude, I never realized there was so much involved in getting a good clean on a windshield. I'm going to try it and see if it works. The jeep is only 10 months old so I'm not convinced that its built up grime but it could be. I noticed this problem after a couple thousand miles after I purchased it and never took it back to the dealer because I find it hard to believe that I am having this issue. I've owned numerous cars with many more miles on the speedometer and have never had a problem this bad. Maybe I should take it back..
 
1 - 5 of 5 Posts
Top