Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
The front wipers will not stop even if the key is off and out. I pulled all the plug on the computer. The switch I removed all of the plugs still going. I got a new motor still going. :banghead: I could use some help here
2007 Unliminted Saraha 4 door
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
If the motors are wired directly to the battery through a relay...I bet the relay went bad and is stuck in the on position. If that's the case, pull the relay and replace it before you need your wipers again.
 

·
Registered
Joined
·
3,646 Posts
s3nt3nc3d said:
If the motors are wired directly to the battery through a relay...I bet the relay went bad and is stuck in the on position. If that's the case, pull the relay and replace it before you need your wipers again.
Good info
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
If the motors are wired directly to the battery through a relay...I bet the relay went bad and is stuck in the on position. If that's the case, pull the relay and replace it before you need your wipers again.
Where the relay I cannot find it in the fuse panel
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
Where the relay I cannot find it in the fuse panel
Honestly have no idea... that's just the best explanation I could come up with based on the info in your post.

On my TJ, all my relays are in a box next to the battery under the hood...I'd guess yours are in a similar location.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The front wipers will not stop even if the key is off and out. I pulled all the plug on the computer. The switch I removed all of the plugs still going. I got a new motor still going. :banghead: I could use some help here
2007 Unliminted Saraha 4 door
Sorry not relays in this model. It really getting to me. I am usally am able to figure this stuff out. I currently ran a switch to my fuse and installed a in line fuse. I dont think my wife will let that go very long. I really dont want to take it to a dealer to tell me what it is. They will tell me its the motor and still have a problem. I am not going down that road. If somebody that know their stuff about that model I would really would be very thankful.
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
There's gotta be relays somewhere...the wipers may be tied into another relay as well so it may not necessarily be labeled as a wiper motor relay.
 

·
Registered
Joined
·
59 Posts
Sounds like the wiper circuit in your TIPM (total integrated power module) went bad. TIPM is the one with all the fuses and relays plugged into it.
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
Any idea where the TIPM is located...seems like that's what the OP is having trouble finding...and since I don't own a JK, I'm not much help in that department.
 

·
Registered
Joined
·
59 Posts
s3nt3nc3d said:
Any idea where the TIPM is located...seems like that's what the OP is having trouble finding...and since I don't own a JK, I'm not much help in that department.
I don't own a JK either but I've seen that problem before. TIPM is the black box near the battery that has all the mini fuses.
 

·
Registered
Joined
·
695 Posts
Go into the box by your battery.. There is a diagram on the panel. With numbers, windshield wipers are in there. You should find your problem there
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #12 ·
The front wipers will not stop even if the key is off and out. I pulled all the plug on the computer. The switch I removed all of the plugs still going. I got a new motor still going. :banghead: I could use some help here
2007 Unliminted Saraha 4 door

Still no luck, I talked to the jeep techs. They told me to unplug the tipm by the front driver side. It didn't make a difference. They also told me their is only one tipm. Relays for the wipers are built into the tipm. Tell me this does the fuse to the wiper should that always be hot or does it only get hot when it gets power:banghead::banghead::banghead::banghead::banghead::banghead::banghead:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #14 ·
I'm pretty sure there is power running when the key is turned on. There shouldn't have power with the key off.
I have power on my fuse panel all the time. You though in might of been the tipm that the fuses plug into. What do you think is a good way to test that board.
 

·
Registered
Joined
·
695 Posts
hefley04 said:
I have power on my fuse panel all the time. You though in might of been the tipm that the fuses plug into. What do you think is a good way to test that board.
They sell current testers at radioshack
 

·
Registered
Joined
·
4 Posts
The front wipers will not stop even if the key is off and out. I pulled all the plug on the computer. The switch I removed all of the plugs still going. I got a new motor still going. :banghead: I could use some help here
2007 Unliminted Saraha 4 door
What worked for me was to turn the wiper switch all the way on quickly then all the way off, all in the span of one wipe. Then they quit. Almost as if you can't use the blinker and wiper arm switches all the way...just a light tap (downward) gets three blinks and one wipe, respectively.
 

·
Registered
Joined
·
15,698 Posts
You guys seem to not understand how the can bus system works

With a can bus many components always have power
For example the radio gets fused battery power at all times

What controls when it is on and off is the TIPM
The TIPM sends a digital can bus signal to the radio to turn it on

The reason it only works with key or key fob is the the wireless ignition module and key or fob chip reader sends a digital can bus signal to TIPM to tell it key position

When a TIPM strays to fail almost any item can turn on or off on its own as the TIPM she senses switch’s like headlight or turn signal then TIPM not switch sends power to components

First pull the wiper fuse to get it to stop

Next you have to decide if TIPM is bad or park feature on wiper motor failed


Sent from my iPhone using Tapatalk
 
1 - 17 of 17 Posts
Top