Jeep Wrangler Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hey guys. Last night I went to put my Jeep in 4 wheel and she didn't go in. The Leaver is easier to pull up then my e brake is it feels as if the lever just came disconnected or something. Does anyone have any suggestions as to what it could be or how to fix it.
 

·
Administrator
Joined
·
12,562 Posts
linkage might need adjustment.. there is an adj ment bolt at the end of linkage towards to the side of the t-case... see if that came off or is free floating.. in most case there should be about 1" or less of rod exposed past the adjuster.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Sweet man thanks I'll check that as soon as I get off work and get back to u. Is it on the driver or passenger side of the transfer case.
 

·
Administrator
Joined
·
12,562 Posts
drivers side...
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
So I crawled underneath n went to check...turns out the whole linkage rod broke off. It was still the stock one on there So I'm gunman get the linkage extension for it.
 

·
Registered
Joined
·
158 Posts
I just replaced my mechanical with Savvy's cable system and it's a lot smoother. It takes a small amount of fine tuning, but I like it better.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
Okay I'll look into it. I have to get heavy duty tie rods n front steering stabilizers then see where I'm sitting on money Cause mechanical is cheaper. lol
 
1 - 12 of 12 Posts
Top