Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1 (Edited)
I have a starting issue...again. Basically replaced the whole ignition system a few months ago for the same reason and had no issues....until the other night. She was parked for a few hours and when I was ready to go she initially started, then stalled...then all I got was cranking and no ignition. I left it alone overnite and tried again in the morning, but no change. Battery is good, fuel is good , but doesnt seem like its getting spark..(pulled different plugs and didnt see it when cranking). Shes def getting fuel, because I can see it going to carb...and smell it. One thing i thought it might be was the coil being loose in its bracket...could this be it? I basically replaced the entire ignition system a few months ago. The only thing that seems off is the coil being loose a bit.......still stuck. 1990 YJ , 4.2 straight 6.
 

·
Founder, ThumbJeeps
Joined
·
4,062 Posts
check for spark, tighten coil down check again, that would at least eliminate that as an option.

When was the last time you changed your cap & rotor???
 

·
Premium Member
Joined
·
10,093 Posts
CPS on the flywheel???
 

·
Registered
Joined
·
146 Posts
Discussion Starter #5
There's no cps on this model. Changed every component in system from distributor, to cap and rotor...they are good. Im thinking of just going to a point based ignition altogether...new distributor and installing points. No more ICM if I do this
 
1 - 5 of 5 Posts
Top