Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter · #1 ·
I have a 99 tj 4.0 5speed it will start with my foot on the gas and if i take my foot off shuts off.
: when driving if put in neutral and let off gas be fine (hold my foot on gas to go)
: after i drive around it will be fine
: before the problem it would stutter it would hold above like 500 and the drop and almost stall but keep running

Also i tested my battery it is fine right around 14v im thinking maybe cap and rotor but it has a new rotor not cap(long story) and maybe the stutter was the throttle body ?
 

·
Registered
Joined
·
3,163 Posts
Well big edit since it's a 5 speed. I think it's the iac. The using neutral to keep it running supports it. Foot on the gas. Edit because I thought you had an auto for some reason then re read. :)

New edit. It's like a valve that let's air into the throttle body to let it run body closed. It fails little or no 02 dies unless foot on gas. That's my guess. Good luck.
 

·
Registered
Joined
·
6,886 Posts
How did you test the battery? Just measuring at the terminals? 14 is what the alt is putting out. That is not a load test. If the battery is weak or has a bad cell, thew PCM will not let the engine run (unless you keep your foot on it). Many of us have been there. Both with my Jeep and a nother Chrysler vehicle.
 

·
Knows a couple things...
Joined
·
49,405 Posts
Does the engine start ok without needing to be jump started? If so, my bet is the IAC (idle air controller) is gunked up & needs cleaning.
 
1 - 7 of 7 Posts
Top