Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
This is about my '97 2.5L with a common vacuum problem: on the highway, when the engine is under load (going uphill), the panel vents slap shut and air whistles through the defrost vent. Once the engine load is relieved and engine vacuum is higher, the vents return to their selected position.

So far, I've replaced the vacuum reservoir, all the under-hood rubber fittings, T-connector and the check valve (the hoses were fine). No dice; the vents continue to slap shut under load.

Just a few minutes ago, I popped the center bezel off the dashboard and pulled out the HVAC box to check the vacuum plugs back there. Everything seems secure. When the engine was cranked and the vent mode selector slid from one position to the next, air could be heard moving through the system as each new position was engaged. When the vent mode was shifted to the Panel position, the sound of moving air never stopped. So now I know there's a leak somewhere in the Panel circuit.

What do you think I should do here? The hoses look fine, and the insulation over them is all in good condition; no pinches or snags anywhere that I could see. I haven't yet dug into the dashboard to hunt down the actuators, but I figure the problem is either going to be at the panel vent actuator or inside the vent mode switch itself.

If it's the actuator, where the heck can I order another one? I can't seem to find them anywhere online. I don't need a "blend door actuator" - it would have to be a panel vent actuator, which is a vacuum device. If the vac leak is inside the vent mode switch, that seems even worse, because I've got one of those oddball HVAC boxes with the one knob and two sliders. Is there any way to repair JUST the switch, or would I have to find a whole new control box?

For such a piddly problem, the solution is sure hard to find. If anyone has some insight into this, I'd appreciate it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
Anybody? Looking for a new vacuum actuator and/or a vacuum switch repair kit. I've been looking since that initial post and still can't find a source.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks, Tokkie. That diagram is what I used when I first started trying to chase down the vacuum leak. Everything under the hood is either A-OK or has been replaced, but the leak is still there.
 
1 - 4 of 4 Posts
Top