Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter · #1 ·
Ok so I went wheeling yesterday, all mud. Had a good time, and Hank (my yj lol) was tearing it up pretty good.

Well on my way home, I took off from a stop light and the acceleration was weak and 'mushy'. Now that I look back, that was the tranny slipping from lack of fluid. Well anyway, I kept heading home and there was a real funny smell and I look in my mirror and the entire highway was covered in smoke from me like a train had gone thru there. Of course I freaked out and pulled over. The tranny was leaking fluid from the bell housing, where the front cover meets it....but it was creamy pink????? The smoke had come from the fluid hitting my exhaust. I let It cool down and I tried to peak and see what the problem was, but I couldn't really see anything. I started it back up and the leaking stopped. I drove it around it circles in the parking lot I was in and it seemed fine. My acceleration was normal and no leaking or smoke. So I get back on the road and decide to stop by autozone to put more fluid in. Well, it was empty of course but it only took two quarts. I started driving again and sure enough, smoke EVERYWHERE. All the way home it was like I had 50 fog machines under my jeep. All the jeep guys I passed were looking at me like a slapped their momma, and a few gave me a thumbs up haha.

I don't know much about tranny's, I'm more of a motor guy. I mean I know how it all works and such, but as far as diagnosis, I'm gonna need ya'lls help

By the way, I've got a '90 YJ with the TF999 tranny
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #2 ·
Nobody?
 

·
Administrator
Joined
·
12,622 Posts
I would drop the pan change the filter and refill for starters, if that does not help then shop time. Might also what to add a larger cooler.
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #4 ·
I did a little research and I'm thinking since I had water up to the doors, the tranny filled up with water, then when I started driving it puked all the extra out...then when I added more fluid, it did it all over again. Are the filters on these things the screen ones? And also how do I know which gasket/filter is for the tf999?
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #5 ·
i dropped the pan and it was all creamy strawberry colored. got as much out as i could, changed the filter and gasket. now i couldnt get every bit out obviously so i noticed that its still a little creamy but not as bad. what i think what was happening is there was enough water mixed in there that it was actually boiling and puking out. i just buttoned it all back up and took it around town. i didnt get up to highway speeds but at least up to 45-50. it shifts fine, has power, and doesnt smoke. im going to take a chance and drive it tmrw. hopefully she wont let me down..
 
1 - 5 of 5 Posts
Top